Sonderzeichen mit Internet Explorer

Ich benutze Microsofts Internet Explorer im Alltag nicht, probiere meine Seite damit aber hin und wieder aus, wenn ich hier am Layout bastle. Dabei hat mich immer schon gestört, daß der IE71 Sonderzeichen wie z.B. die “Angle Brackets” ⟨ (⟨) und ⟩ (⟩) in den Artikel-Fußzeilen und anderen Links nur als „Kästchen“ darstellt. Wenn man jedoch das Kästchen beispielsweise nach Word kopiert, ist alles fein. Ich dachte, HTML 4.01 ist von 1999, der IE7 von 2006, da kann man doch auch von Microsoft erwarten, daß es klappt. *hüstel*

Jetzt hab ich rausgefunden, wie man das Viech zur Kooperation bewegt: Menü Extras → Internetoptionen, dort Allgemein → Schriftarten. In der linken Spalte („Schriftart für Webseiten“) die Schriftart Arial Unicode MS auswählen.2

Dies hat keinerlei Einfluß auf die Darstellung von Webseiten, die eine Schriftart vorgeben (was ja die meisten tun). Aber der IE bequemt sich nach dieser Operation dazu, HTML-Sonderzeichen, die Unicode benötigen, darzustellen. Warum auch immer.

Das funktioniert nur mit der Version 7 des IE3 und interessanterweise auch nur mit Arial Unicode MS; andere Unicode-Schriftarten (z.B. die verbreitetere Lucida Sans Unicode) scheinen nicht zu helfen… Korrektur 03.04.09: Mit der Lucida Sans Unicode geht's doch. Wahrscheinlich hab ich das durcheinandergebracht und meine negativen Erfahrung stammt von einem IE6. Korrektur 03.04.09, die Zweite: Ich hab mich foppen lassen. Ich hab nur drauf geachtet, ob die Hakenpfeile bei den Rückwärtslinks der Fußnoten funktionieren. Die gehen mit der Lucida Sans Unicode. Die Klammern nicht. *gnnnnn*


  1. Beim IE6 klappt's sowieso nicht, aber das will ich ihm altersbedingt nicht anlasten. []
  2. Natürlich muß man die Schriftart erstmal haben… Sie ist, soweit ich weiß, bei MS Office dabei, was diesen Lösungsvorschlag dann doch etwas aufwendiger macht. Korrektur 03.04.09: Die Lucida Sans Unicode, mit der es doch geht wenigstens teilweise geht, ist bei Windows schon dabei. []
  3. Ausprobiert hab ich das unter Windows XP. Ich glaubte, das Problem auch unter Vista gesehen zu haben, als ich vor längerer Zeit mal meinen Laptop damit gebootet habe. Jetzt grad eben hab ich's nochmal ausprobiert und die Darstellung scheint mit IE7/Vista ohne Tricks zu funktionieren; vielleicht gab's da zwischenzeitlich ein Update. Und was uns der neulich veröffentlichte IE8 bringt, weiß ich nicht. []

Kommentar schreiben

Ihre E-Mail-Adresse wird nicht angezeigt oder weitergegeben. Notwendige Felder sind mit * markiert.

This blog is kept spam free by WP-SpamFree.

blogoscoop